Browsers and the Judiciary Website

Today, the New  Jersey Judiciary website began to display a notice on its home page that states “As of June 14, the Judiciary will discontinue support for older browsers in order to comply with information security regulations.  Recommended browsers include Internet Explorer version 10 or higher, Edge, Chrome, or Safari.  If pages do not display properly, you may need to update your browser or try a different browser.”  So if you go to the Judiciary website beginning on Thursday, June 14, and things look odd, the problem may be that your browser is no longer supported for this use.

Leave a Reply